股票开户_股票开户流程_股票开户哪家证券公司好_股票开户网上开户!
股票学习,炒股入门知识
股票开户
股票开户流程
您当前的位置:>首页 -> 股票公式 -> 通达信公式
通达信公式:macd+kdj+rsi+大盘顶底背离指标源码
[  时间:2019-06-25 15:40:28   浏览:174次 ]

流通盘:CAPITAL/1000000,NODRAW;
量比:DYNAINFO(17),NODRAW;
{概念:DYBLOCK,NODRAW;}
{地域:GNBLOCK,NODRAW;}
利润率:FINANCE(43),NODRAW;
DRAWTEXT_FIX(1,0,0,0,'DYBLOCK'+'GNBLOCK');
X1:2*"RSI.RSI1"(6,12,24),COLORWHITE;
X2:=2*"RSI.RSI2"(6,12,24);
150,COLORRED;
底:-50;
顶:50;
TRR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
PDI:= PDM*100/TRR;
MDI:= MDM*100/TRR;
A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9));
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9)),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF"(12,26,9),C1+1)>"MACD.DIF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9));
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
C4:=BARSLAST(REF(CROSS(MDI,PDI),1));
D4:=REF(C,C+1)<C AND REF(MDI,C4+1)>MDI AND CROSS(MDI,PDI);
A4:=BARSLAST(REF(CROSS(PDI,MDI),1));
B4:=REF(C,A4+1)>C AND REF(PDI,A4+1)<PDI AND CROSS(PDI,MDI);
{DMI底背:IF(B4>0,-50,0),COLOR0099FF,POINTDOT;
DRAWTEXT(B4>0,-5,'DMI底背'),COLOR0099FF;}
{DMI顶背:IF(D4>0,50,0),COLORBLUE,POINTDOT;
DRAWTEXT(D4>0,15,'DMI顶背'),COLORBLUE;}
MACD底背:IF(B1>0,-30,0),COLORRED,POINTDOT;
DRAWTEXT(B1>0,-20,'M底'),COLORRED;
MACD顶背:IF(D1>0,30,0),COLOR00FF00,POINTDOT;
DRAWTEXT(D1>0,20,'M顶'),COLOR00FF00;
KDJ底背:IF(B2>0,-20,0),COLORFF00FF,POINTDOT;
DRAWTEXT(B2>0,-10,'K底'),COLORFF00FF;
KDJ顶背:IF(D2>0,20,0),COLORFFCC66,POINTDOT;
DRAWTEXT(D2>0,10,'K顶'),COLORFFCC66;
RSI底背:IF(B3>0,-40,0),COLORYELLOW,POINTDOT;
DRAWTEXT(B3>0,-30,'RSI底'),COLORYELLOW;
RSI顶背:IF(D3>0,40,0),COLORFFFFFF,POINTDOT;
DRAWTEXT(D3>0,30,'RSI顶背'),COLORFFFFFF;
STICKLINE(B1>0,-40,0,0,0),COLORRED;
STICKLINE(B2>0,-35,0,0,0),COLORFF00FF;
STICKLINE(B3>0,-50,0,4,0),COLORYELLOW;
STICKLINE(D1>0,40,0,0,0),COLOR00FF00;
STICKLINE(D2>0,35,0,0,0),COLORFFCC66;
STICKLINE(D3>0,50,0,4,0),COLORWHITE;
{STICKLINE(B4>0,-50,0,0,0),COLOR0099FF;
STICKLINE(D4>0,50,0,0,0),COLORBLUE;}
{STICKLINE("KDJ.J"(80,3,3)<0,25,0,0,0),COLORRED;
STICKLINE("KDJ.J"(80,3,3)>100,25,50,0,0),COLORGREEN;
DRAWTEXT("KDJ.J"(80,3,3)<0,25,'J小于0'),COLORFFCC66;}
{大盘}
DIFFD :=EMA(INDEXC/100,12) - EMA(INDEXC/100,26);
DEAD:=EMA(DIFFD,9);
MACDD:=2*(DIFFD-DEAD);
{RSI}
LCD:=REF(INDEXC,1);
RSID1:=SMA(MAX(INDEXC-LCD,0),6,1)/SMA(ABS(INDEXC-LCD),6,1)*100;
RSID2:=SMA(MAX(INDEXC-LCD,0),12,1)/SMA(ABS(INDEXC-LCD),12,1)*100;
AD1:=BARSLAST(REF(CROSS(DIFFD,DEAD),1));
BD1:=REF(INDEXC,AD1+1)>INDEXC AND REF(DIFFD,AD1+1)<DIFFD AND CROSS(DIFFD,DEAD);
CD1:=BARSLAST(REF(CROSS(DEAD,DIFFD),1));
DD1:=REF(INDEXC,CD1+1)<INDEXC AND REF(DIFFD,CD1+1)>DIFFD AND CROSS(DEAD,DIFFD);
MACDD底背:=IF(BD1>0,-50,0),COLORRED,POINTDOT;
DRAWTEXT(BD1>0,-50,'大盘MACD底背'),COLORRED;
STICKLINE(BD1>0,-50,0,0,0),COLORRED;
MACDD顶背:=IF(DD1>0,50,0),COLOR00FF00,POINTDOT;
DRAWTEXT(DD1>0,50,'大盘MACD顶背'),COLOR00FF00;
STICKLINE(DD1>0,50,0,0,0),COLOR00FF00;
AD3:=BARSLAST(REF(CROSS(RSID1,RSID2),1));
BD3:=REF(INDEXC,AD3+1)>INDEXC AND REF(RSID1,AD3+1)<RSID1 AND CROSS(RSID1,RSID2);
CD3:=BARSLAST(REF(CROSS(RSID2,RSID1),1));
DD3:=REF(INDEXC,CD3+1)<INDEXC AND REF(RSID1,CD3+1)>RSID1 AND CROSS(RSID2,RSID1);
RSID底背:=IF(BD3>0,-50,0),COLORYELLOW,POINTDOT;
DRAWTEXT(BD3>0,-40,'大盘RSI底背'),COLORRED;
STICKLINE(BD3>0,-40,0,0,0),COLORYELLOW;
RSID顶背:=IF(DD3>0,50,0),COLORFFFFFF;
DRAWTEXT(DD3>0,40,'大盘RSI顶背'),COLORFFFFFF;
STICKLINE(DD3>0,40,0,0,0),COLORFFFFFF;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8;
支撑:=L1+P1*0.5/8;
中线:=(支撑+阻力)/2,COLORWHITE,POINTDOT;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:=EMA(V11,3),LINETHICK2,COLORLIMAGENTA;
BB0:=REF(趋势线,1)<11 AND CROSS(趋势线,11) AND C<中线;
DRAWTEXT(BB0,0,'★买'),COLORRED;
DD0:=REF(趋势线,1)>89 AND CROSS(89,趋势线) AND C>中线;
DRAWTEXT(DD0,0,'★卖'),COLORGREEN;
ZTTT:=C>=REF(C,1)*1.07;
MMTT:50*(COUNT(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1)=1 AND ZTTT),COLORYELLOW; 

股票学习 下一篇通达信公式:低位跟进选股指标源码
本栏目最新文章
栏目导航
聊股看盘 | 选股技术 | 每日资讯 | 基本面 | K线图 | MACD学习 | KDJ指标 | 均线指标 | 分时图 | 成交量 | 乖离率 | 布林线 | RSI指标 | 威廉指标 | OBV指标 | 波浪理论 | 股票术语

通达信公式 | 大智慧公式 | 同花顺公式 | 股票软件 | 新股知识 | 交易指南 | 股票基础知识 | 买入技巧 | 跟庄技巧 | 卖出技巧 | 选线技巧 | 看盘技巧 | 股票视频 | 解套技术| 止损技巧

资金管理 | 股票博客