看股票行情_学股票入门基础知识买股票_找股票软件公式_尽在黄金村!
| 留言建议 |加入收藏|
股票入门学习
股票入门学习
您当前的位置:>首页 -> 股票公式 -> 大智慧公式
大智慧公式:涨停金珠主图指标公式
[  时间:2019-03-09 21:16:06   浏览:0次 ]

P1:=3;
P2:=6;
P3:=18;
P4:=250;
DRAWGBKLAST(C>EMA(C,5) ,STRIP(RGB(0,0,80),RGB(80,0,0),1));
DRAWGBKLAST(C<=EMA(C,5),STRIP(RGB(0,0,80),RGB(40,40,0),1));
DRAWGBKLAST(C<=EMA(C,10),STRIP(RGB(0,0,180),RGB(0,80,0),1));
DRAWGBKLAST(C<=EMA(C,20),STRIP(RGB(0,0,80),RGB(0,0,0),1));
{缺口}
LL:=REF(L,1);
HH:=REF(H,1);
SQK:=L>HH;
XQK:=H<LL;
{DRAWTEXT(SQK,L*0.92,' 上跳'),COLORYELLOW;
DRAWTEXT(XQK,H*1.08,' 逃命'),COLORGreen;}
STICKLINE(SQK,L,HH,4*5,1),COLORYELLOW;
STICKLINE(XQK,H,LL,4*5,2),COLORGreen;
{红绿三角【副图】}
A10304:=REF(HIGH,3)=HHV(HIGH,2*3+1);
B10304:=FILTER(A10304,3);
C10304:=BACKSET(B10304,3+1);
D10304:=FILTER(C10304,3);{高点}
A20304:=REF(LOW,3)=LLV(LOW,2*3+1);
B20304:=FILTER(A20304,3);
C20304:=BACKSET(B20304,3+1);
D20304:=FILTER(C20304,3);{低点}
E10304:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E20304:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H10304:=(D10304 AND NOT(D20304 AND E10304>=E20304)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
L10304:=(D20304 AND NOT(D10304 AND E10304=E20304));
X10304:=REF(BARSLAST(H10304),1)+1;
F10304:=BACKSET(H10304 AND COUNT(L10304,X10304)>0,LLVBARS(IF(L10304,LOW,10000),X10304));
G10304:=F10304>REF(F10304,1);
I10304:=BACKSET(G10304,2);
LD0304:=I10304>REF(I10304,1);{过滤后低点}
L20304:=LD0304 OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X20304:=REF(BARSLAST(L20304),1)+1;
F20304:=BACKSET(L20304 AND COUNT(H10304,X20304)>0,HHVBARS(IF(H10304,HIGH,0),X20304));
G20304:=F20304>REF(F20304,1);
I20304:=BACKSET(G20304,2);
HD0304:=I20304>REF(I20304,1);{过滤后高点}
UU0304:=BACKSET(BARSTATUS=2,BARSLAST(LD0304)+1);
VV0304:=UU0304>REF(UU0304,1);
UU20304:=BACKSET(BARSTATUS=2,BARSLAST(HD0304)+1);
VV20304:=UU20304>REF(UU20304,1);
{以下语句为三角形部分}
底:REF(L,BARSLAST(VV0304)),COLORred,LINETHICK1;
顶:REF(H,BARSLAST(VV20304)),COLORGreen,LINETHICK1;
{下跌三角形:红色三角形画完介入}
StickLine(VV0304,顶,底,0,0),COLORred,LINETHICK3;
DRAWLINE(VV20304,H,VV0304,L,0),COLORred,LINETHICK3;{斜}
DRAWLINE(VV20304,H,VV0304,顶,0),COLORred,LINETHICK3;
{上涨三角形:绿色三角形画完出局}
StickLine(VV20304 ,顶,底,0,0),COLORGreen,linethick2;
DRAWLINE(VV0304,L,VV20304,H,0),COLORGreen,linethick2;{斜}
DRAWLINE(VV0304,L,VV20304,底,0),COLORGreen,linethick2;
{文字}
NN304:= DISPSTATUS=2;
DRAWTEXT(nn304,底,'底: '+NUMTOSTRN(底,2)+'元 '),ALIGN2,COLORred,LINETHICK1,VALIGN0;
DRAWTEXT(nn304,顶,'顶: '+NUMTOSTRN(顶,2)+'元 '),ALIGN2,COLORGreen,LINETHICK1,VALIGN2;
{箱体}
TY309:=C;
HD309:=FILTER(BACKSET(FILTER(REF(TY309,10)=HHV(TY309,2*10+1),10),10+1),10);
LD309:=FILTER(BACKSET(FILTER(REF(TY309,10)=LLV(TY309,2*10+1),10),10+1),10);
A309:=REF(C,BARSLAST(HD309));
B309:=REF(C,BARSLAST(LD309));
T1309:=BARSLAST(HD309)<BARSLAST(LD309) AND NOT(HD309) ;
T2309:=BARSLAST(HD309)>BARSLAST(LD309) AND NOT(LD309);
波浪顶:IF(T1309,A309,A309),COLORCYAN,POINTDOT,LINETHICK2;
波浪底:IF(T2309,B309,B309),COLORMAGENTA,POINTDOT,LINETHICK2;
a:=HHV(MA((L+H+C)/3,3),3);
b:=llv(MA((L+H+C)/3,3),10);
STICKLINE(DISPSTATUS=2,a,a,20,0),Coloryellow,linethick1;{小箱体--上沿}
DRAWTEXT(DISPSTATUS=2 ,a,NUMTOSTRN(a,3)),colorYELLOW;
STICKLINE(DISPSTATUS=2,b,b,20,0),COLORWhite,linethick1;{小箱体--下沿}
DRAWTEXT(DISPSTATUS=2,b,NUMTOSTRN(b,3)),COLORWhite;
k1:=llv(l,barslast(DISPSTATUS=1)+1);
aa1:=cost(95);
aa2:=cost(5);
ly:=(aa1-aa2)*100/(aa1+aa2);
N:=p1;{原码 N:=3;}
A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);{高点}
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);{低点}
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2;
E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR DISPSTATUS=2 OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR DISPSTATUS=2 OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);{过滤后高点}
R1:=BACKSET(DISPSTATUS=2,BARSLAST(HD)+1); S1:=R1>REF(R1,1); {前一高}
T1:=BACKSET(DISPSTATUS=2,BARSLAST(LD)+1); U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1); {前三低}
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); U4:=T4>REF(T4,1); {前四低}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1); {前三高}
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); S4:=R4>REF(R4,1); {前四高}
DRAWLINE(S2,H,S1,H,1),Color80FFFF; {★压力1:}
DRAWLINE(U2,L,U1,L,1),POINTDOT,Color00FFFF,linethick1;{★支撑1:}
DRAWLINE(S3,H,S2,H,1),ColorFF8000; {★压力2:}
DRAWLINE(U3,L,U2,L,1),POINTDOT,ColorFF8000;{★支撑2:}
DRAWLINE(S4,H,S3,H,1),Color0000FF;{★压力3:}
DRAWLINE(U4,L,U3,L,1),POINTDOT,Color0000FF;{★支撑3:};
DRAWICON(S2,H*1.02,9);{高点红电池}
DRAWICON(S3,H*1.02,9);
DRAWTEXT(S2,H*1.035,NUMTOSTRN(H,2)),COLORMAGENTA,linethick2;{高价点位}
DRAWTEXT(S1,H*1.035,NUMTOSTRN(H,2)),COLORMAGENTA,linethick2;{高价点位}
DRAWTEXT(S3,H*1.035,NUMTOSTRN(H,2)),COLORMAGENTA,linethick2;{高价点位}
DRAWICON(U1,L*0.98,10); {低点小红旗}
DRAWICON(U2,L*0.98,10);{低点小红旗}
DRAWICON(U3,L*0.98,10);{低点小红旗}
DRAWICON(U4,L*0.98,10);{低点小红旗}
DRAWTEXT(U1,L*0.96,NUMTOSTRN(L,2)),COLORCYAN,linethick2;{低价点位}
DRAWTEXT(U2,L*0.96,NUMTOSTRN(L,2)),COLORCYAN,linethick2;{低价点位}
DRAWTEXT(U3,L*0.96,NUMTOSTRN(L,2)),COLORCYAN,linethick2;{低价点位}
DRAWTEXT(U4,L*0.96,NUMTOSTRN(L,2)),COLORCYAN,linethick2;{低价点位}
{K线变色}
{STICKLINE(open>=close ,close ,open,0,0 ),COLOR00FF00;
STICKLINE(open>=close ,close ,open,8,0 ),COLOR008800;
STICKLINE(open>=close ,close ,open,7,0 ),COLOR009900;
STICKLINE(open>=close ,close ,open,6,0 ),COLOR00AA00;
STICKLINE(open>=close ,close ,open,5,0 ),COLOR00BB00;
STICKLINE(open>=close ,close ,open,4,0 ),COLOR00CC00;
STICKLINE(open>=close ,close ,open,3,0 ),COLOR00DD00;
STICKLINE(open>=close ,close ,open,2,0 ),COLOR00EE00;
STICKLINE(open>=close ,close ,open,1,0 ),COLOR00FF00;
STICKLINE(close>open,close,open,0,0) ,COLORFFBBFF;
STICKLINE(close>open,close,open,8,0) ,COLORFF00FF;
STICKLINE(close>open,close,open,7,0) ,COLORFF22FF;
STICKLINE(close>open,close,open,6,0) ,COLORFF44FF;
STICKLINE(close>open,close,open,5,0) ,COLORFF66FF;
STICKLINE(close>open,close,open,4,0) ,COLORFF88FF;
STICKLINE(close>open,close,open,3,0) ,COLORFF99FF;
STICKLINE(close>open,close,open,2,0) ,COLORFFAAFF;
STICKLINE(close>open,close,open,1,0) ,COLORFFBBFF;};
{基本面}
DRAWTEXTABS(20,5,'所属板块:'+BKNAME),COLORyellow;
流通盘大小:=FINANCE2(37)/1000000*100;
DRAWTEXTABS(20,25,'上市日期:'+STR(FINANCE2(2))+'日'),Coloryellow;
DRAWTEXTABS(180,25,'总股本:'+NUMTOSTR(FINANCE2(35)/10000 )+'亿'),COLORyellow;
DRAWTEXTABS(320,25,'流通股:'+ NUMTOSTR(CAPITAL/1000000)+'亿'),COLORyellow;
DRAWTEXTABS(460,25,'限售A股:'+ NUMTOSTR(FINANCE2(41)/10000)+'亿'),COLORyellow;
每股收益:=FINANCE2(3);
每股市盈率:=DYNAINFO(39);
每股净资产:=FINANCE2(4);
销售毛利率:=FINANCE2(12);
主营收入同比:=FINANCE2(11);
净利润同比增长:=FINANCE2(10);
每股公积金:=FINANCE2(7);
每股未分配:=FINANCE2(8);
DRAWTEXTABS(20,45,'销售毛利率:'+NUMTOSTRN(销售毛利率,2)+'%'),COLORgreen;
DRAWTEXTABS(20,65,'主营收入同比增长:'+NUMTOSTRN(主营收入同比,2)+'%'),COLORgreen;
DRAWTEXTABS(20,85,'净利润同比增长:'+NUMTOSTRN(净利润同比增长,2)+'%'),COLORgreen;
DRAWTEXTABS(20,105,'每股公积金:'+NUMTOSTRN(每股公积金,2)+'元'),Colorgreen;
DRAWTEXTABS(180,45,'每股收益:'+NUMTOSTRN(每股收益,2)+ '元'),COLORred;
DRAWTEXTABS(180,65,'每股市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),COLORred;
DRAWTEXTABS(180,85,'每股净资产:'+NUMTOSTRN(每股净资产,2)+'元'),COLORred;
DRAWTEXTABS(180,105,'每股未分配:'+NUMTOSTRN(每股未分配,2)+'元'),Colorred;
n1:=barslast(cross(c,MA(c,60)));
n2:=barslast(cross(MA(c,60),c));
建仓成本:=MAXCYC;
日换手率:=(VOL*100/CAPITAL);;
5日换手率:=SUM(日换手率,5);;
5日均量:=DYNAINFO(38);
压力位:=DMA(AMOUNT/(100*VOL),VOL/(100*FINANCE2(37)))*1.12;
强股排序:=if(n1<n2,n1+1,0);
DRAWTEXTABS(320,45,'日换手率:'+NUMTOSTRN(日换手率,3)),ColorF200F2;
DRAWTEXTABS(460,45,'5日换手率:'+NUMTOSTRN(5日换手率,3)),ColorF200F2;
DRAWTEXTABS(320,65,'5日均量:'+NUMTOSTRN(5日均量,0)+'手'),ColorF200F2;
DRAWTEXTABS(460,65,'平均成本:'+NUMTOSTRN(建仓成本,2)+'元'),ColorF200F2;
DRAWTEXTABS(320,85,'股价上穿60均线:'+NUMTOSTRN(强股排序,0)+'天'),ColorF200F2;
DRAWTEXTABS(460,85,'心理成本压力:'+NUMTOSTRN(压力位,2)+'元'),ColorF200F2;
DRAWTEXTABS(320,105,'上涨家数:'+NUMTOSTRN(INDEXADV,0)),COLORF200F2;
DRAWTEXTABS(460,105,'下跌家数:'+NUMTOSTRN(INDEXDEC,0)),COLORF200F2;
drawtextabs(5,260,'【红三角】〓回调企稳形态【突破红三角后的回踩为 假摔】〓'),COLORred,linethick2;
drawtextabs(5,285,'【红三角】〓回调企稳形态【画完介入&突破介入】〓'),COLORred,linethick2;
drawtextabs(5,310,'【绿三角】〓突破前高形态【画完出局】〓'),COLORGreen,linethick2;
drawtextabs(5,335,'【绿三角】〓突破前高形态【未突破绿三角顶端的回调为 真摔】〓'),COLORGreen,linethick2;
ST:=STRFIND(stkname,'ST',1);
ZF:=(c-ref(c,1))/ref(c,1)*100;
涨停:=IF(ST>0,ZF>=4.94,ZF>=9.88);
跌停:=IF(ST>0,ZF<=-4.94,ZF<=-9.88);
{涨停金柱}
STICKLINE(涨停>=1,O,C,15,0),COLOR004444;
STICKLINE(涨停>=1,O,C,13,0),COLOR004444;
STICKLINE(涨停>=1,O,C,11,0),COLOR004444;
STICKLINE(涨停>=1,O,C,10,0),COLOR004444;
STICKLINE(涨停>=1,O,C,7,0),COLOR005555;
STICKLINE(涨停>=1,O,C,6,0),COLOR006666;
STICKLINE(涨停>=1,O,C,5,0),COLOR007777;
STICKLINE(涨停>=1,O,C,4,0),COLOR009999;
STICKLINE(涨停>=1,O,C,3,0),COLOR00bbbb;
STICKLINE(涨停>=1,O,C,2,0),COLOR00dddd;
STICKLINE(涨停>=1,O,C,1,0),COLOR00ffff;
{DRAWTEXT(涨停>0,L*1.01,'↖涨停'),COLOR00FFFF;}
{跌停银柱}
STICKLINE(跌停>=1,O,C,15,0),COLOR333333;
STICKLINE(跌停>=1,O,C,13,0),COLOR333333;
STICKLINE(跌停>=1,O,C,11,0),COLOR333333;
STICKLINE(跌停>=1,O,C,10,0),COLOR333333;
STICKLINE(跌停>=1,O,C,7,0),COLOR444444;
STICKLINE(跌停>=1,O,C,6,0),COLOR555555;
STICKLINE(跌停>=1,O,C,5,0),COLOR777777;
STICKLINE(跌停>=1,O,C,4,0),COLOR999999;
STICKLINE(跌停>=1,O,C,3,0),COLORbbbbbb;
STICKLINE(跌停>=1,O,C,2,0),COLORdddddd;
STICKLINE(跌停>=1,O,C,1,0),COLORffffff;
{DRAWTEXT(跌停>0,H*1.01,'↙跌停'),COLORFFFFFF;};
{LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背离'), ColorD8BFD8;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'顶背离'),COLOR00FFFF;}
三连阴:={COUNT(C<REF(C,1),3)>2 AND} COUNT(C<=O,3)>2 AND REF(C,1)<REF(C,2);
二缩量:=VOL<=REF(VOL,1) AND REF(VOL,1)<REF(VOL,2);
三阴:=REF(ALL(C<REF(C,1),2)AND ALL(C<O,2),1) AND ABS(C-O)/O<0.03
AND SUM((C-REF(C,1))/C*100,7)<-8 AND 二缩量 AND IF(C>O,C/O<REF(O/C,1),O/C<REF(O/C,1))AND
REF(O/C<REF(O/C,1),1);
DRAWTEXT(三阴,H*1.01,'三阴'),COLOR00dddd;
{三长假跌}
RC1:=REF(C,1);
比前跌率:=(RC1-C)*100/RC1;
长上影:=(H-MAX(C,O))/(H-L)>=0.618;{这个可自调0.5-0.66}
不大跌:= 比前跌率<=2;{这个可自调0.5-3}
长阴短柱:=比前跌率>=4 AND V<HHV(V,30)/1.9;
长腿:=(MIN(C,O)-L)/(H-L)>=0.382;{这个可自调0.3-0.66}
点左峰:=1;{暂时不考虑}
XG1:= REF(长上影 AND 不大跌,2)>0
AND REF(长阴短柱,1)>0
AND 长腿 AND 点左峰;
三长假跌:= COUNT(XG1,3);{3天内出现信号选出,这个3可往大调,如果选不出};
DRAWTEXT(三长假跌,L*0.99,'三长'),COLORf00ff0;
长阴短柱:=C/REF(C,1)<0.95 AND V<HHV(V,30)/1.9;
DRAWTEXT(长阴短柱,L*0.99,'长阴短');
假阴真阳:=V>REF(V,1)*1.5 AND O>REF(C,1) AND C<O AND C>REF(C,1);
DRAWTEXT(假阴真阳,L*0.99,'假阴真阳');
假阳真阴:=C>O and C<REF(C,1);
DRAWTEXT(假阳真阴,H*1.01,'假阳真阴');

股票学习 下一篇大智慧指标公式:红蓝导航主图
本栏目最新文章
栏目导航
聊股看盘 | 选股技术 | 每日资讯 | 基本面 | K线图 | MACD学习 | KDJ指标 | 均线指标 | 分时图 | 成交量 | 乖离率 | 布林线 | RSI指标 | 威廉指标 | OBV指标 | 波浪理论 | 股票术语

通达信公式 | 大智慧公式 | 同花顺公式 | 股票软件 | 新股知识 | 交易指南 | 股票基础知识 | 买入技巧 | 跟庄技巧 | 卖出技巧 | 选线技巧 | 看盘技巧 | 股票视频 | 解套技术| 止损技巧

资金管理 | 股票博客